Multivariate Statistics  (MARS 6300) - Homework 2     Name:  _______________________

Distributed:  Tuesday, February  6, 2018     Due:  Thursday, February 22, 2018   

Instructions:  Copy and paste your answers below and turn in a word file and two excel files by the end of due day via email to khyrenba@gmail.com. Please use email title “MARS 6300 hw#2” and label all files with you’re a suffix including your name (e.g., MARS6300_hw2_hyrenbach). Unlabeled emails / files will be penalized 10% of points.     

You are free to use any reference materials of your choice.  While you are encouraged to work together, make sure you turn your own assignment.  This homework is worth 5 points.   Make sure you leave the formulas showing all of your calculations in the excel file, and explain your reasoning, to get partial credit.

The objectives of this homework are:
A) To review and practice data transformations.
B) To calculate dissimilarities for a simple species / sample matrix.
C) To perform a clustering analysis.
D) To practice reporting the results of clustering analyses. 

To complete this homework, you will need:
· Instruction file:  “BIOL6300_hw2.doc” (open with word file) – turn in
· “desserts colors.xls” data file: (open with excel) – do not turn in
· “aMoss1M.WK1” data file: (open with PC-ORD) – do not turn in

1)  Data Transformations: 
A) Download and open the file “MossStems1M.WK1”dataset (This is dataset 2.1 from web-site).  Summarize the data to look for “problematic” species distributions.  Inspect “result.txt” file for the following information:
Copy and paste the kurtosis values for all 50 species below:
What is the average skewness (across all 50 species) ? ______
How many species have skewness values > 1 or < -1? 


We need to make some transformations to get the species abundance data to be more normally distributed.  What transformation do you recommend?  To answer this question, check the ranges of possible values (Hint: are there any negative values, are there values smaller than 1)?

What is the most numerous species? _________ 
What is its maximum abundance? _________
What is the least numerous species? _________ 
What is its maximum abundance? _________

Note:  You can inspect the species abundances using the ‘Graph > Dominance Curves” menu.  Create two graphs of the sum and the log(sum) of species abundance versus species rank. Label the axes and the species.  Finally, using these figures and the output summary table as reference, discuss the relative abundance of the species in this sample.
(Hint:  append the new output to your “result.txt” file – it creates a log of your steps for you)

Let’s try the log transform (of all the species data at once).  Use the “Modify Data > Transformations > Logarithmic” menu (select: ln(x) with base 10).  What happened?  Why? 

 If the previous transformation did not work, you can fix this problem by adding a constant to all of the data.  Think carefully about what value would you add. Base your answer on the results you obtained from the screening of the data. 
Once you have added a constant to all of the data (to all of the species), perform the log transform and re-summarize the data, to see what are the skewness values for the 50 species.
Copy and paste the kurtosis values for all 50 species (after the transformation) below:

What is the average skewness (across all 50 species) ?________
How many species have skewness values > 1 or < -1? 

Did the log transform decrease the skewness for all species?  Explain why / why not?

Finally, transform these species abundances into presence / absence data using another transformation.  Which one would you use to achieve this?  Explain what you are actually doing to transform these abundance values into a binary response: 0 (absent) and 1 (present). 

2) Distance measures: 
Import file “desserts colors.xls” and use the data provided to explore distance measures:
· To begin, calculate the correlations between all the pairs of samples (the people), in terms of their color and dessert choices (together). Use the “Summary > Write Distance Matrix” command to calculate the correlations. Make sure you request an xls output file – it is easier to work with than the Result.txt screen.

Open the file and report how many pairwise correlations are reported:  ___________

Show why this number of pairwise matches makes sense: ____________________

 Calculate and report the following statistics for the correlation:  	
	Mean
	

	STD
	

	Min
	

	Max
	



Calculate and report the following statistics for the correlation-based distance:  	
	Mean
	

	STD
	

	Min
	

	Max
	



Use the formula provided in the lecture to convert the                                                                          maximum and the minimum correlation coefficients                                                                                   into correlation-based distance measures (r distance):   

	Correlation Coefficient
	r distance

	Maximum r = 
	

	[bookmark: _GoBack]Minimum r =
	



What happened to the correlation coefficients for the two most correlated and the two least correlated pairs of samples, when you calculated the distances measures? Explain:    


Next, calculate the following stats for four distance measures:
	
	Correlation
	Euclidean
	SQ_Euclidean
	Rel_Euclidean

	mean
	
	
	
	

	STD
	
	
	
	

	min
	
	
	
	

	max
	
	
	
	



Using the same pair of samples, make three separate regressions of the Euclidean distances (x axis) versus the distances of: (i) correlation distance, (ii) Squared Euclidean distances, and (iii) Relative Euclidean distances (y axis).  For each regression, fit the best-fit line (using linear regression “anchored” at the origin (point 0, 0) – so the intercept or constant is “zero”).  Discuss if the different distances measures are distorted, compared with the Euclidean distances Hint: Ask for the residual plot and paste it below, along with the r-squared.  How good is the linear fit? Can you see any patterns in the residuals?   
Fill in this table:
	Distance Measure Comparison
	Adjusted R squared                         (from regression)
	Pattern in residuals
(Do they appear random: yes / no?)

	Euclidean X Correlation
	
	

	Euclidean X SQ Euclidean
	
	

	Euclidean X Rel Euclidean
	
	








Finally, calculate the Sorensen distance matrix for the “desserts colors” dataset.  
What happened? Why? 



[image: ]3)   Clustering analysis of a small dataset:
A)  Enter this main data matrix, showing the abundance of two species on four different sample plots, into PC ORD.  You can use “File > New > Main Matrix” menu.  Note:  remember the formatting conventions for rows and columns, and add sample numbers and species numbers. Save data set for later using “Save As > Main” menu.

B) Create scatterplot, showing the four samples in “species space”. Label each sample.  Paste figure below. Using this figure, describe which two samples are “closer” to each other?  Why?

Using this same logic, draw a diagram (bubbles and arrows) showing the way you think the clustering of these samples would look like.  Do not worry about the size of the x and the y axis (the distances), I just want you to show me the order in which samples would be added to the dendogram  (Hint:  look at slide 3 from lecture 8).  Create figure with the software of your choice (ppt, draw, or else).  You can even draw figure manually and insert digital image below:  

C)  Calculate the Euclidean distances between plot 1 and plot 2, between plot 1 and plot 3, and between plot 1 and plot 4.   Hint, use formula from lecture 6 (dimensions k = 2).  Report the Euclidean distances below:
plot 1 vs plot 2:
plot 1 vs plot 3:
plot 1 vs plot 4:
Next, use PC ORD to calculate the dissimilarity matrix using the Euclidean distance measure.  Use “Summary > Write Distance matrix” menu.    Request both a “result.txt” file and a “full matrix” as a spreadsheet (.wk1) so you can re-load it into PC ORD).   Copy and paste table of pair-wise distances from result.txt in table provided below: 
    Distance measure = Euclidean (also called Pythagorean)       
             D I S T A N C E    M A T R I X  (Euclidean Distances)
	
	P1
	P2
	P3
	P4

	P1
	
	
	
	

	P2
	
	
	
	

	P3
	
	
	
	

	P4
	
	
	
	



Check your answers against the values calculated by PC ORD. 
Remember:  Clustering uses squared distances.  Calculate the squared distances (d 2) below:
     Distance measure = d 2  = (Euclidean) 2       

                        D I S T A N C E    M A T R I X  (Euclidean Distance Squared)
	
	P1
	P2
	P3
	P4

	P1
	
	
	
	

	P2
	
	
	
	

	P3
	
	
	
	

	P4
	
	
	
	



D) Next, you will combine the data of plot 1 and plot 2 because they are the most similar.
Calculate the mean number of species 1 and species 2 in the union of plot 1 and plot 2.
Mean_species1 (mean of plot 1 and plot 2):
Mean_species2 (mean of plot 1 and plot 2):
Calculate E resulting from creation of this group (union of plot 1 and plot2) using this equation:
[image: ]
Where the number “1” means this is the first “step” in the clustering procedure.
And where i is the sample (plot 1 or 2) and j is the species (1 or 2).  
Hint:  Remember, you just calculated averages for both species abundance across both samples. 
Write out the terms you are summing to get E1 (above) and report the value:

E) Now that you created the first cluster (union of 1 and 2), we need to calculate the distances between this cluster and the other two samples (p3 and p4) using the Ward linkage method.
Use the formulas below:
where the values of p, q, , and  determine the type of sorting strategy 
(Use Ward coefficients, listed below).

[image: ]
 NOTE:   n is the number of samples (n = 1 unless you are looking at a group)

Subscript “i” refers to the remaining plots not in the group (plot 3 or plot 4)  (Hint: ni = 1)
Subscript “r” refers to the group you created (union of plot 1 and plot 2) (Hint: nr = 2)
Subscript “p” refers to plot 1                                        Subscript “q” refers to plot 2
So:  [image: ]
Go to your table of squared distances and extract the following values. Paste values below:

 = distance between plot 1 and plot 3: 

 = distance between plot 1 and plot 4: 

 = distance between plot 3 and plot 4: 
So, the squared distance between plot 3 and plot 1+2 (the union of plot 1 and 2)  is:
[image: ]
Enter coefficients and distances into the same equation shown above to calculate the squared distance between plot 4 and plot 1+2.  Show the sum for calculating the distance squared below:
[image: ]
     (Hint, I show you the other squared distances – in matrix below - for reference)
[image: ]

[image: ]4)  Now, you will let PC ORD do all of this for you.
Load the original dataset you created previously back into PC ORD, and run clustering analysis using “Groups > Cluster Analysis” menu. 

[image: ][image: ]Use the following set up:

Once you run clustering analysis, PC ORD will create a graph.   
Inspect graph after looking at the “result.txt” file. 
Copy and paste dendogram – from graphs.  Use “Graph> Dendogram” menu to look at figure.
(Hint:  play with graph settings, and try “save as” and “copy / paste” menus)

5)  Review of Clustering Papers:
Read the three papers on clustering and report the following information, pertaining to “hierarchical clustering analyses”, for each paper.  Please be brief but provide enough detail.              A word or a sentence will suffice. NOTE:  please do not report results from K-means clustering.  

A) He et al. 1997: 
- Describe data Matrix:  how many samples / species, what are these data?
- List data transformations and explain rationale:
- Distance Measure employed: 
- Linkage Method employed:
- If dendogram plotted, was it re-scaled, explain what method used:
- If groups were defined, was rule for “prunning” the tree provided:
- If dendogram was plotted, did it display the amount of information retained:
- Finally, were the resulting groups characterized?  How?

B) Wolter 1987: 
- Describe data Matrix:  how many samples / species, what are these data?
- List data transformations and explain rationale:
- Distance Measure employed: 
- Linkage Method employed:
- If dendogram plotted, was it re-scaled, explain what method used:
- If groups were defined, was rule for “prunning” the tree provided:
- If dendogram was plotted, did it display the amount of information retained:
- Finally, were the resulting groups characterized?  How?

C) Diehr et al. 1982: 
- Describe data Matrix:  how many samples / species, what are these data?
- List data transformations and explain rationale:
- Distance Measure employed: 
- Linkage Method employed:
- If dendogram plotted, was it re-scaled, explain what method used:
- If groups were defined, was rule for “prunning” the tree provided:
- If dendogram was plotted, did it display the amount of information retained:
- Finally, were the resulting groups characterized?  How?


6) Perform Clustering Analysis:  
Analyze “dessert color” dataset.  Download and import “desertscolors.xls” file using “File > Import Matrix > Main” menu.  Note:  data are on first sheet.  (This is dataset 2.2 from web-site).  

Calculate Euclidean distance and perform a clustering analysis with the Ward Method.
Request same set up as you used in question 4, but request 13 groups (instead of 3, as you did before).  Make sure you select “write all higher level groupings.  
Why is the maximum number of groups 13?  Explain: 
[image: ]
Look at the graph of the dendogram and make sure you select “groups to be labeled” under the “Options> Preferences” menu.  




Cycle through the different groups, using the “Groups > Select Grouping Variable” menu.  

What is the “group” grouping variable showing you?  
(Hint: How does the figure change as you increase the “grouping variable”). 

Open the “result.txt” file and look for the levels for the various cluster cycles.
For instance, the level is 88 (8.8000E+01)for cluster 1 and 2484.143 for cycle 13

------------- C L U S T E R   C Y C L E     1 -------------
 Combined group    12   into group     4   at level 8.8000E+01
  
------------- C L U S T E R   C Y C L E    13 -------------
 Combined group     7   into group     1   at level 2.4841E+03

Copy and paste the values into the table below:
	cycle number
	level
	%_explained
	%_info_remaining

	1
	88
	3.54
	96.46

	2
	 
	 
	 

	3
	 
	 
	 

	4
	 
	 
	 

	5
	 
	 
	 

	6
	 
	 
	 

	7
	 
	 
	 

	8
	 
	 
	 

	9
	 
	 
	 

	10
	 
	 
	 

	11
	 
	 
	 

	12
	 
	 
	 

	13
	2484.143
	100
	0



At what cycle did we explain over 50% of the pattern?   What was the exact r 2?
If cycle 1 creates two groups, how many groups did we have at the cycle when over 50 of the pattern was explained?  
Select that number of groups using the “Groups > Select Grouping Variable” menu, and copy and paste the figure below.    
4
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